18

Is the DN redesign broken on Safari (OS X)?

almost 6 years ago from , Design Director @ Damn Fine

I'm not sure what's going on with it, and I'm surprised there's been no thread about it if it's not just me, but I've tried everything to no avail. OS X Safari just seems to hate the new DN. I couldn't upvote or comment, I couldn't create threads, I tried logging out and now I can't log back in. So I came into Chrome, and everything works perfectly. What's the deal?

I've tried disabling all extensions and I'm not seeing any major errors in the console, it's really bizarre.

13 comments

  • Tristam Goch, over 5 years ago

    Weirdly, everything works fine if I have the inspector open...

    3 points
    • Marc EdwardsMarc Edwards, over 5 years ago

      I've had trouble submitting articles and commenting.

      Weirdly, everything works fine if I have the inspector open...

      OMG. And now it works.

      4 points
      • Taylor Van OrdenTaylor Van Orden, over 5 years ago

        Does it work when you load the page and then open inspector, or when you have inspector open and then load the page?

        The reason some things work with inspector open is opening the inspector forces a repaint of the browser (resizing your screen would also have the same effect) after all the elements are loaded. Sometimes its a oddity or a weirdly implemented spec on the browsers behalf, sometimes its due to loading things in a not optimal order on the website's part.

        I ran into it in Chrome about a year ago due to some webfont loading issues: https://www.reddit.com/r/css/comments/1ziela/problem_webfonts_occasionally_not_displaying/

        I do not use Safari, but I can tell you that testing and debugging on Safari today is a lot shittier than a year or two ago. This article pretty much sums up my thoughts on Safari at the moment: http://nolanlawson.com/2015/06/30/safari-is-the-new-ie/

        0 points
    • Joseph Decker, over 5 years ago

      (2) Confirming that I also have no problems using Safari.

      I've actually swapped to Safari, simple because Chrome isn't doing it for me right now — the CPU peaks are too extreme.

      3 points
  • Jody HeavenerJody Heavener, over 5 years ago

    Hey everyone!

    Thanks for bringing this to our attention. I'm going to take a look today to see if I can nail down the issue. We're also going to be making a handful of Javascript improvements in the next week or so. In the mean time, the best way to submit feedback like this would be to use our handy feedback icon in the bottom right. That way we won't lose track of it ;)

    2 points
  • David Foltz, almost 6 years ago

    Using Safari 9 I can't log in via the link at top of page.

    1 point
  • Mike BaileyMike Bailey, almost 6 years ago

    I've also noticed on the IPhone 6 in safari the main menu horizontal scroller selection is borked.

    I'll try submit a screenshot later.

    1 point
  • Cristian MoiseiCristian Moisei, almost 6 years ago

    Here's another comments bug:

    https://www.dropbox.com/s/xjxqdbbq8twnn07/Screenshot%202015-07-12%2019.08.14.png?dl=0

    0 points
  • Account deleted almost 6 years ago

    My only issues have been mobile safari on iOS. I've stopped even trying because it was so wildly buggy... so it could be better now.

    0 points
  • Jesse HeadJesse Head, over 5 years ago

    The only way I could log in was by clicking on a post first and then clicking the yellow log in button vs the button in the nav bar.

    0 points
  • Cristian MoiseiCristian Moisei, almost 6 years ago
    • 1 for submitting comments and articles. I reported this to their support team and I assume they will be looking into it.
    0 points
  • Anwar ChoukahAnwar Choukah, over 5 years ago (edited over 5 years ago )

    Oops

    0 points
  • BAKA .kidBAKA .kid, over 5 years ago

    i had some trouble logging in. as if the link wouldn't click. but when reloaded everything seems to work. but I'm new here, so I'm not sure what its meant to be like.

    0 points